References

[1] Mell, P., and Grance, T.. The NIST Definition of Cloud Computing. NIST SP 800-145, 2011. https://csrc.nist.gov/pubs/sp/800/145/final

[2] Iorga, M., et al.. Fog Computing Conceptual Model. NIST SP 500-325, 2018. https://www.nist.gov/publications/fog-computing-conceptual-model

[3] Ollama. Generate a chat message. API documentation; accessed September 17, 2026. https://docs.ollama.com/api/chat

[4] Ollama. Structured Outputs. Documentation; accessed September 17, 2026. https://docs.ollama.com/capabilities/structured-outputs

[5] Banks, A., Briggs, E., Borgendale, K., and Gupta, R., eds.. MQTT Version 5.0. OASIS Standard, March 7, 2019. https://docs.oasis-open.org/mqtt/mqtt/v5.0/os/mqtt-v5.0-os.html

[6] Shelby, Z., Hartke, K., and Bormann, C.. The Constrained Application Protocol (CoAP). RFC 7252, 2014. https://www.rfc-editor.org/rfc/rfc7252.html

[7] Connectivity Standards Alliance. Matter. Official overview; accessed September 15, 2026. https://csa-iot.org/all-solutions/matter/

[8] Fielding, R., Nottingham, M., and Reschke, J., eds.. HTTP Semantics. RFC 9110, 2022. https://www.rfc-editor.org/rfc/rfc9110.html

[9] Iyengar, J., and Thomson, M., eds.. QUIC: A UDP-Based Multiplexed and Secure Transport. RFC 9000, 2021. https://www.rfc-editor.org/rfc/rfc9000.html

[10] Docker. What is a container?. Documentation; accessed September 15, 2026. https://docs.docker.com/get-started/docker-concepts/the-basics/what-is-a-container/

[11] Docker. Resource constraints. Documentation; accessed September 15, 2026. https://docs.docker.com/engine/containers/resource_constraints/

[12] Kubernetes. Cluster Architecture. Documentation; accessed September 15, 2026. https://kubernetes.io/docs/concepts/architecture/

[13] Python Software Foundation. time: Time access and conversions. Documentation; accessed September 15, 2026. https://docs.python.org/3/library/time.html

[14] Amazon Web Services. What is AWS IoT Greengrass?. V2 Developer Guide; rechecked September 20, 2026. https://docs.aws.amazon.com/greengrass/v2/developerguide/what-is-iot-greengrass.html

[15] Amazon Web Services. How AWS IoT Greengrass works. V2 Developer Guide; rechecked September 20, 2026. https://docs.aws.amazon.com/greengrass/v2/developerguide/how-it-works.html

[16] Amazon Web Services. AWS IoT Greengrass component recipe reference. V2 Developer Guide; accessed September 17, 2026. https://docs.aws.amazon.com/greengrass/v2/developerguide/component-recipe-reference.html

[17] Amazon Web Services. Test AWS IoT Greengrass components with local deployments. V2 Developer Guide; accessed September 15, 2026. https://docs.aws.amazon.com/greengrass/v2/developerguide/test-components.html

[18] Amazon Web Services. Tutorial: Interact with local IoT devices over MQTT. V2 Developer Guide; accessed September 17, 2026. https://docs.aws.amazon.com/greengrass/v2/developerguide/client-devices-tutorial.html

[19] Amazon Web Services. MQTT bridge. V2 Developer Guide; accessed September 17, 2026. https://docs.aws.amazon.com/greengrass/v2/developerguide/mqtt-bridge-component.html

[20] Amazon Web Services. AWS IoT Device Shadow service. IoT Core Developer Guide; rechecked September 20, 2026. https://docs.aws.amazon.com/iot/latest/developerguide/iot-device-shadows.html

[21] Amazon Web Services. AWS Outposts racks FAQs. Official FAQ; rechecked September 20, 2026. https://aws.amazon.com/outposts/rack/faqs/

[22] Amazon Web Services. What is AWS Wavelength?. Documentation; rechecked September 20, 2026. https://docs.aws.amazon.com/wavelength/latest/developerguide/what-is-wavelength.html

[23] NIST. IoT Device Cybersecurity Capability Core Baseline. NISTIR 8259A, 2020. https://csrc.nist.gov/pubs/ir/8259/a/final

[24] NIST. Guide to Operational Technology (OT) Security. NIST SP 800-82 Revision 3, 2023. https://csrc.nist.gov/pubs/sp/800/82/r3/final

[25] Rose, S., Borchert, O., Mitchell, S., and Connelly, S.. Zero Trust Architecture. NIST SP 800-207, 2020. https://csrc.nist.gov/pubs/sp/800/207/final

[26] Yaga, D., Mell, P., Roby, N., and Scarfone, K.. Blockchain Technology Overview. NISTIR 8202, 2018. https://csrc.nist.gov/pubs/ir/8202/final

[27] Connectivity Standards Alliance. Distributed Compliance Ledger. Official overview; accessed September 17, 2026. https://csa-iot.org/certification/distributed-compliance-ledger/

[28] Kwon, W., et al.. Efficient Memory Management for Large Language Model Serving with PagedAttention. SOSP 2023; arXiv:2309.06180. https://arxiv.org/abs/2309.06180

[29] Leviathan, Y., Kalman, M., and Matias, Y.. Fast Inference from Transformers via Speculative Decoding. ICML 2023, PMLR 202. https://proceedings.mlr.press/v202/leviathan23a.html

[30] Ong, I., et al.. RouteLLM: Learning to Route LLMs with Preference Data. arXiv:2406.18665, 2024. https://arxiv.org/abs/2406.18665

[31] Narayan, A., et al.. Minions: Cost-efficient Collaboration Between On-device and Cloud Language Models. arXiv:2502.15964, 2025; rechecked September 20, 2026. https://arxiv.org/abs/2502.15964

[32] Wang, C., et al.. SLM-MUX: Orchestrating Small Language Models for Reasoning. ICLR 2026; rechecked September 20, 2026. https://proceedings.iclr.cc/paper_files/paper/2026/hash/77b874452cdb52ea04c15b33122969e9-Abstract-Conference.html

[33] Zhang, Y., Gao, Z., Yue, S., Li, J., and Wang, R.. A Pipelined Collaborative Speculative Decoding Framework for Efficient Edge-Cloud LLM Inference. arXiv:2603.19133, March 2026; preprint; rechecked September 20, 2026. https://arxiv.org/abs/2603.19133

[34] McMahan, B., Moore, E., Ramage, D., Hampson, S., and Arcas, B. A. y.. Communication-Efficient Learning of Deep Networks from Decentralized Data. AISTATS 2017, PMLR 54. https://proceedings.mlr.press/v54/mcmahan17a.html

[35] Bonawitz, K., et al.. Practical Secure Aggregation for Privacy-Preserving Machine Learning. ACM CCS 2017. https://research.google/pubs/practical-secure-aggregation-for-privacy-preserving-machine-learning/

[36] NIST. Guidelines for Evaluating Differential Privacy Guarantees. NIST SP 800-226, 2025. https://csrc.nist.gov/pubs/sp/800/226/final

[37] Amazon Web Services. MQTT. IoT Core Developer Guide; accessed September 15, 2026. https://docs.aws.amazon.com/iot/latest/developerguide/mqtt.html

[38] Amazon Web Services. Create deployments. V2 Developer Guide; accessed September 17, 2026. https://docs.aws.amazon.com/greengrass/v2/developerguide/create-deployments.html

[39] Espressif Systems. ESP-IDF Programming Guide: Get Started (ESP32). Official documentation or author source; accessed September 20, 2026. https://docs.espressif.com/projects/esp-idf/en/stable/esp32/get-started/index.html

[40] STMicroelectronics. STM32 Nucleo development boards. Official documentation or author source; accessed September 20, 2026. https://www.st.com/en/evaluation-tools/stm32-nucleo-boards.html

[41] Raspberry Pi. Pico-series microcontroller documentation. Official documentation or author source; accessed September 20, 2026. https://www.raspberrypi.com/documentation/microcontrollers/pico-series.html

[42] Raspberry Pi. Raspberry Pi computer documentation. Official documentation or author source; accessed September 20, 2026. https://www.raspberrypi.com/documentation/computers/raspberry-pi.html

[43] NVIDIA. Jetson modules: embedded computing platform overview. Official documentation or author source; accessed September 20, 2026. https://developer.nvidia.com/embedded/jetson-modules

[44] Bosch Sensortec. BME280 environmental sensor overview. Official documentation or author source; accessed September 20, 2026. https://www.bosch-sensortec.com/products/environmental-sensors/humidity-sensors-bme280/

[45] Bosch Sensortec. BMI270 inertial measurement unit overview. Official documentation or author source; accessed September 20, 2026. https://www.bosch-sensortec.com/products/motion-sensors/imus/bmi270/

[46] Sensirion. SCD41 product and measurement principle overview. Official documentation or author source; accessed September 20, 2026. https://sensirion.com/products/catalog/SCD41

[47] STMicroelectronics. VL53L1X time-of-flight sensor overview. Official documentation or author source; accessed September 20, 2026. https://www.st.com/en/imaging-and-photonics-solutions/vl53l1x.html

[48] Texas Instruments. Millimeter-wave radar sensor overview. Official documentation or author source; accessed September 20, 2026. https://www.ti.com/sensors/mmwave-radar/overview.html

[49] Android Developers. Sensors overview. Official documentation or author source; accessed September 20, 2026. https://developer.android.com/develop/sensors-and-location/sensors/sensors_overview

[50] Android Developers. Motion sensors. Official documentation or author source; accessed September 20, 2026. https://developer.android.com/develop/sensors-and-location/sensors/sensors_motion

[51] Android Developers. Optimize location use for battery life. Official documentation or author source; accessed September 20, 2026. https://developer.android.com/develop/sensors-and-location/location/battery

[52] Linux kernel documentation. SocketCAN: Controller Area Network. Official documentation or author source; accessed September 20, 2026. https://docs.kernel.org/networking/can.html

[53] ROS community. REP 103: Standard Units of Measure and Coordinate Conventions. Official documentation or author source; accessed September 20, 2026. https://raw.githubusercontent.com/ros-infrastructure/rep/master/rep-0103.rst

[54] Smith, S. W.. The Scientist and Engineer’s Guide to Digital Signal Processing: The Sampling Theorem. Official documentation or author source; accessed September 20, 2026. https://www.dspguide.com/ch3/2.htm

[55] Nordic Semiconductor. nRF9160 cellular IoT system-in-package overview. Official documentation or author source; accessed September 20, 2026. https://www.nordicsemi.com/Products/nRF9160

[56] Bluetooth SIG. The Bluetooth Low Energy Primer. Official documentation or author source; accessed September 20, 2026. https://www.bluetooth.com/bluetooth-resources/the-bluetooth-low-energy-primer/

[57] Bluetooth SIG. Core Specification 6.1: Generic Attribute Profile (GATT). Official documentation or author source; accessed September 20, 2026. https://www.bluetooth.com/wp-content/uploads/Files/Specification/HTML/Core-61/out/en/host/generic-attribute-profile--gatt-.html

[58] Bluetooth SIG. Bluetooth Mesh overview. Official documentation or author source; accessed September 20, 2026. https://www.bluetooth.com/learn-about-bluetooth/feature-enhancements/mesh/

[59] Thread Group. What is Thread? Architecture overview. Official documentation or author source; accessed September 20, 2026. https://www.threadgroup.org/What-is-Thread/Overview

[60] Connectivity Standards Alliance. Zigbee overview. Official documentation or author source; accessed September 20, 2026. https://csa-iot.org/all-solutions/zigbee/

[61] LoRa Alliance. About LoRaWAN. Official documentation or author source; accessed September 20, 2026. https://lora-alliance.org/about-lorawan/

[62] IETF. RFC 6282: Compression Format for IPv6 Datagrams over IEEE 802.15.4-Based Networks. Official documentation or author source; accessed September 20, 2026. https://www.rfc-editor.org/rfc/rfc6282.html

[63] IETF. RFC 6550: RPL—IPv6 Routing Protocol for Low-Power and Lossy Networks. Official documentation or author source; accessed September 20, 2026. https://www.rfc-editor.org/rfc/rfc6550.html

[64] IETF. RFC 8613: Object Security for Constrained RESTful Environments (OSCORE). Official documentation or author source; accessed September 20, 2026. https://www.rfc-editor.org/rfc/rfc8613.html

[65] IETF. RFC 7641: Observing Resources in the Constrained Application Protocol. Official documentation or author source; accessed September 20, 2026. https://www.rfc-editor.org/rfc/rfc7641.html

[66] IETF. RFC 8323: CoAP over TCP, TLS, and WebSockets. Official documentation or author source; accessed September 20, 2026. https://www.rfc-editor.org/rfc/rfc8323.html

[67] Object Management Group. Data Distribution Service (DDS), version 1.4. Official documentation or author source; accessed September 20, 2026. https://www.omg.org/spec/DDS/1.4/About-DDS

[68] eProsima. Fast DDS: Standard QoS Policies. Official documentation or author source; accessed September 20, 2026. https://fast-dds.docs.eprosima.com/en/latest/fastdds/dds_layer/core/policy/standardQosPolicies.html

[69] OPC Foundation. OPC Unified Architecture overview. Official documentation or author source; accessed September 20, 2026. https://opcfoundation.org/about/opc-technologies/opc-ua/

[70] Blesson Varghese, Nan Wang, Sakil Barbhuiya, Peter Kilpatrick, and Dimitrios S. Nikolopoulos. Challenges and Opportunities in Edge Computing. IEEE SmartCloud, 2016; arXiv:1609.01967; accessed September 21, 2026. https://arxiv.org/abs/1609.01967

[71] Arduino. UNO R3. Hardware documentation and technical specifications; accessed September 21, 2026. https://store.arduino.cc/products/arduino-uno-rev3

[72] Raspberry Pi. Raspberry Pi Pico 2. Product specifications; accessed September 21, 2026. https://www.raspberrypi.com/products/raspberry-pi-pico-2/

[73] Raspberry Pi. Raspberry Pi 5. Product specifications; accessed September 21, 2026. https://www.raspberrypi.com/products/raspberry-pi-5/

[74] NVIDIA. Jetson Orin Nano Super Developer Kit. Product specifications; accessed September 21, 2026. https://www.nvidia.com/en-us/autonomous-machines/embedded-systems/jetson-orin/nano-super-developer-kit/

[75] Google. Data Center Photo Gallery. Official facility photographs and captions; accessed September 21, 2026. https://datacenters.google/discover-more/photo-gallery/

[76] Amazon Web Services. Specifications for Amazon EC2 general purpose instances. EC2 documentation; m7i.large configuration; accessed September 21, 2026. https://docs.aws.amazon.com/ec2/latest/instancetypes/gp.html

[77] Amazon Web Services. What is AWS Outposts?. AWS Outposts documentation; accessed September 21, 2026. https://docs.aws.amazon.com/outposts/latest/userguide/what-is-outposts.html

[78] Clarity Movement. Clarity Node-S Air Sensor. Product and deployment description; accessed September 21, 2026. https://www.clarity.io/products/clarity-node-s

[79] ETSI. Multi-access Edge Computing (MEC). Technical-group overview; accessed September 21, 2026. https://www.etsi.org/technical-groups/mec/

[80] Amazon Web Services. What is Amazon CloudFront?. CloudFront developer guide; accessed September 21, 2026. https://docs.aws.amazon.com/AmazonCloudFront/latest/DeveloperGuide/Introduction.html

[81] Anthropic. Building effective agents. Engineering article, December 19, 2024; accessed September 21, 2026. https://www.anthropic.com/engineering/building-effective-agents

[82] Yao, S., et al.. ReAct: Synergizing Reasoning and Acting in Language Models. ICLR 2023; arXiv:2210.03629v3. https://arxiv.org/abs/2210.03629

[83] Ollama. Tool calling. Official documentation; accessed September 21, 2026. https://docs.ollama.com/capabilities/tool-calling

[84] Hugging Face. Secure code execution. smolagents documentation; accessed September 21, 2026. https://huggingface.co/docs/smolagents/tutorials/secure_code_execution

[85] Docker. What is an image?. Official documentation; consulted 2026-10-05. https://docs.docker.com/get-started/docker-concepts/the-basics/what-is-an-image/

[86] Docker. Multi-platform builds. Official documentation; consulted 2026-10-05. https://docs.docker.com/build/building/multi-platform/

[87] Docker. Volumes. Official documentation; consulted 2026-10-05. https://docs.docker.com/engine/storage/volumes/

[88] Docker. Protect the Docker daemon socket. Official documentation; consulted 2026-10-05. https://docs.docker.com/engine/security/protect-access/

[89] Docker. How services work. Official documentation; consulted 2026-10-05. https://docs.docker.com/engine/swarm/how-swarm-mode-works/services/

[90] Docker. Use Swarm mode routing mesh. Official documentation; consulted 2026-10-05. https://docs.docker.com/engine/swarm/ingress/

[91] Docker. docker service create. Official documentation; consulted 2026-10-05. https://docs.docker.com/reference/cli/docker/service/create/

[92] Kubernetes. Deployments. Official documentation; consulted 2026-10-05. https://kubernetes.io/docs/concepts/workloads/controllers/deployment/

[93] Kubernetes. Service. Official documentation; consulted 2026-10-05. https://kubernetes.io/docs/concepts/services-networking/service/

[94] Kubernetes. Configure Liveness, Readiness and Startup Probes. Official documentation; consulted 2026-10-05. https://kubernetes.io/docs/tasks/configure-pod-container/configure-liveness-readiness-startup-probes/

[95] Kubernetes. Resource Management for Pods and Containers. Official documentation; consulted 2026-10-05. https://kubernetes.io/docs/concepts/configuration/manage-resources-containers/

[96] Kubernetes. Horizontal Pod Autoscaling. Official documentation; consulted 2026-10-05. https://kubernetes.io/docs/concepts/workloads/autoscaling/horizontal-pod-autoscale/

[97] Kubernetes. Node Autoscaling. Official documentation; consulted 2026-10-05. https://kubernetes.io/docs/concepts/cluster-administration/node-autoscaling/

[98] Knative. Serving. Official documentation; consulted 2026-10-05. https://knative.dev/docs/serving/

[99] Knative. Configuring scale to zero. Official documentation; consulted 2026-10-05. https://knative.dev/docs/serving/autoscaling/scale-to-zero/

[100] Amazon Web Services. Understanding the Lambda execution environment lifecycle. Official documentation; consulted 2026-10-05. https://docs.aws.amazon.com/lambda/latest/dg/lambda-runtime-environment.html

[101] SQLite. Transaction. Official documentation; consulted 2026-10-05. https://www.sqlite.org/lang_transaction.html

[102] Kubernetes. Kubernetes Scheduler. Official documentation; consulted 2026-10-05. https://kubernetes.io/docs/concepts/scheduling-eviction/kube-scheduler/

[103] Kubernetes. Container Runtimes. Official documentation; consulted 2026-10-05. https://kubernetes.io/docs/setup/production-environment/container-runtimes/

[104] Kubernetes. Use Port Forwarding to Access Applications in a Cluster. Official documentation; consulted 2026-10-05. https://kubernetes.io/docs/tasks/access-application-cluster/port-forward-access-application-cluster/

[105] Python Software Foundation. http.server: HTTP servers. Official documentation; consulted 2026-10-05. https://docs.python.org/3/library/http.server.html

[106] Docker. docker buildx build. Official documentation; consulted 2026-10-05. https://docs.docker.com/reference/cli/docker/buildx/build/

[107] Amazon Web Services. AWS Wavelength FAQs. Official documentation; checked October 5, 2026. https://aws.amazon.com/wavelength/faqs/

[108] Amazon Web Services. Architect apps for Wavelength. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/wavelength/latest/developerguide/architecture.html

[109] Amazon Web Services. Quotas and considerations for Wavelength Zones. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/wavelength/latest/developerguide/wavelength-quotas.html

[110] Amazon Web Services. AWS Nitro System. Official documentation; checked October 5, 2026. https://aws.amazon.com/ec2/nitro/

[111] Amazon Web Services. Control traffic to your AWS resources using security groups. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/vpc/latest/userguide/vpc-security-groups.html

[112] Amazon Web Services. Giving Lambda functions access to resources in an Amazon VPC. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/lambda/latest/dg/configuration-vpc.html

[113] Amazon Web Services. How AWS Local Zones work. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/local-zones/latest/ug/how-local-zones-work.html

[114] Amazon Web Services. Run AWS Lambda functions on AWS IoT Greengrass. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/greengrass/v2/developerguide/run-lambda-functions.html

[115] Amazon Web Services. Getting started with AWS Local Zones. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/local-zones/latest/ug/getting-started.html

[116] Amazon Web Services. Connectivity through service link. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/outposts/latest/userguide/service-links.html

[117] Amazon Web Services. Deploy Amazon EKS on-premises with AWS Outposts. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/eks/latest/userguide/eks-outposts.html

[118] Amazon Web Services. Differences between CloudFront Functions and Lambda@Edge. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/AmazonCloudFront/latest/DeveloperGuide/edge-functions-choosing.html

[119] Amazon Web Services. Restrictions on CloudFront Functions. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/AmazonCloudFront/latest/DeveloperGuide/cloudfront-function-restrictions.html

[120] Amazon Web Services. Restrictions on Lambda@Edge. Official documentation; checked October 5, 2026. https://docs.aws.amazon.com/AmazonCloudFront/latest/DeveloperGuide/lambda-at-edge-function-restrictions.html

[121] Cloudflare. How Workers works. Official documentation; checked October 5, 2026. https://developers.cloudflare.com/workers/reference/how-workers-works/

[122] Cloudflare. Workers limits. Official documentation; checked October 5, 2026. https://developers.cloudflare.com/workers/platform/limits/

[123] Cloudflare. Workers placement. Official documentation; checked October 5, 2026. https://developers.cloudflare.com/workers/configuration/placement/

[124] National Institute of Standards and Technology. Definitions and State of the Art: Digital Twins. https://www.nist.gov/digital-twins/definitions-and-state-art Accessed October 6, 2026.

[125] National Institute of Standards and Technology. Essential Elements: Digital Twins. https://www.nist.gov/digital-twins/essential-elements Accessed October 6, 2026.

[126] Microsoft. Learn about twin models and how to define them in Azure Digital Twins. https://learn.microsoft.com/en-us/azure/digital-twins/concepts-models Accessed October 6, 2026.

[127] Microsoft. Ingest IoT Hub telemetry into Azure Digital Twins. https://learn.microsoft.com/en-us/azure/digital-twins/how-to-ingest-iot-hub-data Accessed October 6, 2026.

[128] Amazon Web Services. What is AWS IoT TwinMaker? AWS IoT TwinMaker User Guide. https://docs.aws.amazon.com/iot-twinmaker/latest/guide/what-is-twinmaker.html Accessed October 6, 2026.

[129] National Institute of Standards and Technology. Validating and Advancement: Digital Twins. https://www.nist.gov/digital-twins/validating-and-advancement Accessed October 6, 2026.

[130] scikit-learn. load_digits: dataset description and loader. https://scikit-learn.org/stable/modules/generated/sklearn.datasets.load_digits.html Accessed October 6, 2026.

[131] scikit-learn. Metrics and scoring: quantifying the quality of predictions. https://scikit-learn.org/stable/modules/model_evaluation.html Accessed October 6, 2026.

[132] PyTorch. How ExecuTorch Works. https://docs.pytorch.org/executorch/stable/intro-how-it-works.html Accessed October 6, 2026.

[133] ONNX Runtime. Execution Providers. https://onnxruntime.ai/docs/execution-providers/ Accessed October 6, 2026.

[134] Google AI Edge. LiteRT for Microcontrollers. https://developers.google.com/edge/litert/microcontrollers/overview Accessed October 6, 2026.

[135] Lin et al. MCUNet: Tiny Deep Learning on IoT Devices. NeurIPS 2020. https://arxiv.org/abs/2007.10319 Accessed October 6, 2026.

[136] Howard et al. MobileNets: Efficient Convolutional Neural Networks for Mobile Vision Applications. 2017. https://arxiv.org/abs/1704.04861 Accessed October 6, 2026.

[137] Sandler et al. MobileNetV2: Inverted Residuals and Linear Bottlenecks. CVPR 2018. https://arxiv.org/abs/1801.04381 Accessed October 6, 2026.

[138] Google AI Edge. LiteRT 8-bit quantization specification. https://developers.google.com/edge/litert/conversion/tensorflow/quantization/quantization_spec Accessed October 6, 2026.

[139] Google AI Edge. Post-training quantization. https://developers.google.com/edge/litert/conversion/tensorflow/quantization/post_training_quantization Accessed October 6, 2026.

[140] Jacob et al. Quantization and Training of Neural Networks for Efficient Integer-Arithmetic-Only Inference. CVPR 2018. https://arxiv.org/abs/1712.05877 Accessed October 6, 2026.

[141] ONNX Runtime. Quantize ONNX models. https://onnxruntime.ai/docs/performance/model-optimizations/quantization.html Accessed October 6, 2026.

[142] PyTorch. torchao documentation: model optimization and quantization. https://docs.pytorch.org/ao/stable/index.html Accessed October 6, 2026.

[143] Han et al. Learning both Weights and Connections for Efficient Neural Networks. NeurIPS 2015. https://arxiv.org/abs/1506.02626 Accessed October 6, 2026.

[144] Li et al. Pruning Filters for Efficient ConvNets. ICLR 2017. https://arxiv.org/abs/1608.08710 Accessed October 6, 2026.

[145] PyTorch. Pruning Tutorial. https://docs.pytorch.org/tutorials/intermediate/pruning_tutorial.html Accessed October 6, 2026.

[146] TensorFlow Model Optimization. Pruning for on-device inference with XNNPACK. https://www.tensorflow.org/model_optimization/guide/pruning/pruning_for_on_device_inference Accessed October 6, 2026.

[147] Hinton, Vinyals, and Dean. Distilling the Knowledge in a Neural Network. 2015. https://arxiv.org/abs/1503.02531 Accessed October 6, 2026.

[148] PyTorch. Knowledge Distillation Tutorial. https://docs.pytorch.org/tutorials/beginner/knowledge_distillation_tutorial.html Accessed October 6, 2026.

[149] ONNX Runtime. Graph optimizations. https://onnxruntime.ai/docs/performance/model-optimizations/graph-optimizations.html Accessed October 6, 2026.

[150] PyTorch. Memory Planning Inspection in ExecuTorch. https://docs.pytorch.org/executorch/stable/memory-planning-inspection.html Accessed October 6, 2026.

[151] Android Developers. Thermal API. https://developer.android.com/games/optimize/adpf/thermal Accessed October 6, 2026.

[152] Google AI Edge. PyTorch to LiteRT quickstart. https://developers.google.com/edge/litert/conversion/pytorch/overview Accessed October 6, 2026.

[153] Han, Mao, and Dally. Deep Compression: Compressing Deep Neural Networks with Pruning, Trained Quantization and Huffman Coding. ICLR 2016. https://arxiv.org/abs/1510.00149 Accessed October 6, 2026.

[154] Teerapittayanon, McDanel, and Kung. BranchyNet: Fast Inference via Early Exiting from Deep Neural Networks. 2017 preprint. https://arxiv.org/abs/1709.01686 Accessed October 6, 2026.

[155] Guo et al. On Calibration of Modern Neural Networks. ICML, 2017. https://proceedings.mlr.press/v70/guo17a.html Accessed October 6, 2026.

[156] Kang et al. Neurosurgeon: Collaborative Intelligence Between the Cloud and Mobile Edge. ASPLOS, 2017. https://dl.acm.org/doi/10.1145/3037697.3037698 Accessed October 6, 2026.

[157] Teerapittayanon, McDanel, and Kung. Distributed Deep Neural Networks over the Cloud, the Edge and End Devices. 2017. https://arxiv.org/abs/1709.01921 Accessed October 6, 2026.

[158] Hugging Face Transformers. Caching: key/value states and autoregressive inference. https://huggingface.co/docs/transformers/en/cache_explanation Accessed October 6, 2026.

[159] ggml-org. llama.cpp: official source and inference documentation. https://github.com/ggml-org/llama.cpp Accessed October 6, 2026.

[160] Ollama. Frequently asked questions: local execution, memory, and concurrency. https://docs.ollama.com/faq Accessed October 6, 2026.

[161] Chen, Zaharia, and Zou. FrugalGPT: How to Use Large Language Models While Reducing Cost and Improving Performance. 2023. https://arxiv.org/abs/2305.05176 Accessed October 6, 2026.

[162] Hu et al. LoRA: Low-Rank Adaptation of Large Language Models. 2021 preprint. https://arxiv.org/abs/2106.09685 Accessed October 6, 2026.

[163] Dettmers et al. QLoRA: Efficient Finetuning of Quantized LLMs. 2023. https://arxiv.org/abs/2305.14314 Accessed October 6, 2026.

[164] Zhu, Liu, and Han. Deep Leakage from Gradients. 2019. https://arxiv.org/abs/1906.08935 Accessed October 6, 2026.

[165] Hugging Face Transformers. Chat templates. https://huggingface.co/docs/transformers/en/chat_templating Accessed October 6, 2026.

[166] vLLM project. Official serving implementation and documentation. https://github.com/vllm-project/vllm Accessed October 6, 2026.

[167] Ollama. List local models: artifact metadata and digests. https://docs.ollama.com/api/tags Accessed October 6, 2026.

[168] Lewis et al. Retrieval-Augmented Generation for Knowledge-Intensive NLP Tasks. NeurIPS 2020. https://arxiv.org/abs/2005.11401 Accessed October 6, 2026.

[169] Ollama. Embeddings for semantic search and retrieval. https://docs.ollama.com/capabilities/embeddings Accessed October 6, 2026.

[170] Model Context Protocol. Tools specification, revision 2025-11-25. https://modelcontextprotocol.io/specification/2025-11-25/server/tools Accessed October 6, 2026.

[171] Model Context Protocol. Security best practices. https://modelcontextprotocol.io/docs/2025-11-25/tutorials/security/security_best_practices Accessed October 6, 2026.

[172] Python. ast: abstract syntax trees. https://docs.python.org/3/library/ast.html Accessed October 6, 2026.

[173] gVisor. Architecture and security overview. https://gvisor.dev/docs/ Accessed October 6, 2026.

[174] Docker. Docker Engine security. https://docs.docker.com/engine/security/ Accessed October 6, 2026.

[175] LangChain. LangGraph persistence. https://docs.langchain.com/oss/python/langgraph/persistence Accessed October 6, 2026.

[176] Amazon Builders’ Library. Making retries safe with idempotent APIs. https://aws.amazon.com/builders-library/making-retries-safe-with-idempotent-APIs/ Accessed October 6, 2026.

[177] SQLite. Atomic commit in SQLite. https://sqlite.org/atomiccommit.html Accessed October 6, 2026.

[178] RFC 8446. The Transport Layer Security (TLS) Protocol Version 1.3 (2018). https://www.rfc-editor.org/rfc/rfc8446.html Accessed October 6, 2026.

[179] NIST SP 800-193. Platform Firmware Resiliency Guidelines (2018). https://csrc.nist.gov/pubs/sp/800/193/final Accessed October 6, 2026.

[180] RFC 9124. A Manifest Information Model for Firmware Updates in Internet of Things (IoT) Devices (2022). https://www.rfc-editor.org/rfc/rfc9124.html Accessed October 6, 2026.

[181] RFC 9334. Remote ATtestation procedureS (RATS) Architecture (2023). https://www.rfc-editor.org/rfc/rfc9334.html Accessed October 6, 2026.

[182] Kubernetes. Multi-tenancy. https://kubernetes.io/docs/concepts/security/multi-tenancy/ Accessed October 6, 2026.

[183] Python Cryptographic Authority. Ed25519 signing. cryptography 46.0.4 documentation. https://cryptography.io/en/46.0.4/hazmat/primitives/asymmetric/ed25519/ Accessed October 6, 2026.

[184] RFC 8785. JSON Canonicalization Scheme (JCS) (2020). https://www.rfc-editor.org/rfc/rfc8785.html Accessed October 6, 2026.

[185] Hyperledger Fabric. The Ordering Service. https://hyperledger-fabric.readthedocs.io/en/latest/orderer/ordering_service.html Accessed October 6, 2026.

[186] Hyperledger Fabric. Private data. https://hyperledger-fabric.readthedocs.io/en/latest/private-data/private-data.html Accessed October 6, 2026.

[187] Hyperledger Fabric. Smart Contracts and Chaincode. https://hyperledger-fabric.readthedocs.io/en/latest/smartcontract/smartcontract.html Accessed October 6, 2026.

[188] Connectivity Standards Alliance. Distributed Compliance Ledger: official project overview and architecture. https://github.com/zigbee-alliance/distributed-compliance-ledger Accessed October 6, 2026.

[189] Connectivity Standards Alliance. DCL how-to guide: read and write access. https://github.com/zigbee-alliance/distributed-compliance-ledger/blob/master/docs/how-to.md Accessed October 6, 2026.

[190] RFC 9162. Certificate Transparency Version 2.0 (2021). https://www.rfc-editor.org/rfc/rfc9162.html Accessed October 6, 2026.

[191] RFC 9200. Authentication and Authorization for Constrained Environments Using the OAuth 2.0 Framework (ACE-OAuth) (2022). https://www.rfc-editor.org/rfc/rfc9200.html Accessed October 6, 2026.

[192] NIST AI 100-2 E2025. Adversarial Machine Learning: A Taxonomy and Terminology of Attacks and Mitigations (2025). https://csrc.nist.gov/pubs/ai/100/2/e2025/final Accessed October 6, 2026.

[193] The Update Framework. Overview. https://theupdateframework.io/docs/overview/ Accessed October 6, 2026.

[194] NASA. SWE-051 — Software Requirements Analysis. NASA Software Engineering Handbook. Accessed October 26, 2026. Source

[195] NASA. SWE-109 — Software Requirements Specification. NASA Software Engineering Handbook. Accessed October 26, 2026. Source

[196] Akamai. Akamai Company History — The Akamai Story. Commercial-service launch in April 1999. Accessed October 28, 2026. Source

[197] Satyanarayanan, M., Bahl, P., Cáceres, R., and Davies, N. The Case for VM-Based Cloudlets in Mobile Computing. IEEE Pervasive Computing, 8(4), 14–23, 2009. DOI: 10.1109/MPRV.2009.82. Source

[198] Bonomi, F., Milito, R., Zhu, J., and Addepalli, S. Fog Computing and Its Role in the Internet of Things. Proceedings of the MCC Workshop on Mobile Cloud Computing, 13–16, 2012. DOI: 10.1145/2342509.2342513. Source

[199] ETSI. New ETSI Mobile-Edge Computing Industry Specification Group Starts Work. December 12, 2014. Source

[200] ETSI. ETSI Multi-access Edge Computing Starts Second Phase and Renews Leadership Team. March 28, 2017. Source

[201] Amazon Web Services. AWS Greengrass Is Now Generally Available. June 7, 2017. Historical announcement of the original service. Source

[202] Varda, K. Introducing Cloudflare Workers: Run JavaScript Service Workers at the Edge. Cloudflare Blog, September 29, 2017; availability update March 13, 2018. Source

[203] Apple. Apple Intelligence Foundation Language Models. Technical report, July 2024. Source

[204] Apple. Apple Intelligence Foundation Language Models Tech Report 2025. Technical report, July 2025. Source

[205] Apple. Introducing the Third Generation of Apple’s Foundation Models. June 8, 2026. Historical announcement; accessed October 28, 2026. Source

[206] Shi, W., Cao, J., Zhang, Q., Li, Y., and Xu, L. Edge Computing: Vision and Challenges. IEEE Internet of Things Journal, 3(5), 637–646, 2016. DOI: 10.1109/JIOT.2016.2579198. Source

[207] Sinha, S. State of IoT 2025: Number of Connected IoT Devices Growing 14% to 21.1 Billion Globally. IoT Analytics, October 28, 2025. Retrospective estimate for 2024 and forecasts for 2025 and 2030; methodology counts active connections, not all individual sensors. Source

[208] Rotaru, A. Edge Computing Global Spending to Grow at 15%, Reaching $450 Billion by 2029. IDC, February 26, 2026 (release dateline: February 25). 2025 spending estimate and 2029 forecast from the Worldwide Edge Spending Guide. Source

[209] Sheshadri, S. H., Karumbunathan, L. S., and Franklin, D. NVIDIA Jetson Orin Nano Developer Kit Gets a “Super” Boost. NVIDIA Technical Blog, December 17, 2024. Configuration comparison: Table 1; sparse INT8 throughput, memory bandwidth, and historical listed kit prices. Vendor specifications, not independent application benchmarks. Source

[210] Abdin, M., et al. Phi-3 Technical Report: A Highly Capable Language Model Locally on Your Phone. Microsoft; arXiv:2404.14219v1, April 22, 2024, Section 2 and Figure 1. Quantized-model footprint and author-reported A16 Bionic iPhone demonstration. Source

[211] Akamai Technologies. Akamai Reports Fourth Quarter 2000 and Fiscal Year 2000 Financial Results. January 24, 2001. Company-reported year-end 2000 network: over 8,000 servers, 473 networks, 55 countries. Source

Photograph and product-image credits

P1. Arduino UNO R3 board. 3. Multi-Layer Computing_ IoT.pptx; slide 17.

P2. Raspberry Pi 5 board. 3. Multi-Layer Computing_ IoT.pptx; slide 7.

P5. Outdoor Clarity air-sensing installation. 3. Multi-Layer Computing_ IoT.pptx; slide 72.

P6. Shelf cameras and lighting. 1. Introduction to Edge Computing (26W).pptx; slide 37.

P7 · Figure 1.5. Advantech. UNO-137 Integrated IoT Edge with Optimized Flexibility. Manufacturer product/expansion illustration; user-supplied file pt_01.png. Source. Publication permission has not been documented.

P8 · Figure 1.6(a). SimonWaldherr. Google Pixel. Photograph, 10 February 2024; Wikimedia Commons; user-supplied file 2.jpg. Source · CC BY-SA 4.0. Displayed at reduced size; no additional cropping or retouching.

P9 · Figure 1.6(b). Tom’s Hardware (image credit). Photograph accompanying Les Pounder, “Nvidia’s New Orin Nano Developer Kit: Like a Raspberry Pi for AI,” 21 March 2023; user-supplied file 3.jpg. Source. Publication permission has not been documented. Both kits are retained without cropping.

P10 · Figure 1.7. Dell Technologies. PowerEdge XR4000 with VMware Edge Compute Stack for Edge Computing, 31 August 2023, Table 1, stackable XR4000z configuration. Manufacturer product image; user-supplied file 4.png. Source. Publication permission has not been documented.

P11 · Figure 1.8(a). Toni Birrer. Dell PowerEdge R610. Photograph, 22 April 2009; Wikimedia Commons version originally sourced from Flickr; user-supplied file 5.jpg. Source · CC BY-SA 2.0. The source file is already cropped; no further crop or retouching was added. Displayed at reduced size.

P12 · Figure 1.8(b). Carl Lender. Datacenter Server Racks (22370909788). Photograph, 4 November 2015; Wikimedia Commons, originally sourced from Flickr; user-supplied file 6.jpg. Source · CC BY 2.0. Displayed at reduced size; no additional cropping or retouching.

P13 · Figure 1.8(c). Lambtron. Google data center. Photograph of The Dalles, Oregon, 23 June 2020; Wikimedia Commons; user-supplied file 7.jpg. Source · CC BY-SA 4.0. Displayed at reduced size; no additional cropping or retouching.

Source and publication note. P1–P2 and P5–P6 retain the source records from v0.4.1; their original authorship and publication permissions remain to be verified. P3–P4 are not used in this illustrated revision. The seven new images were supplied by the user, and the linked source pages were checked on 27 October 2026. Creative Commons images retain their stated licenses; source and license links accompany each credit. Manufacturer and media images are included for this review draft, with publication permissions still to be confirmed. Labels are outside the photographs; no generated imagery, reconstruction, or claims of newly tested deployments have been added.